XOOPS 2.0.16, News 1.53 e Editores WYSIWYG

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
RUBENS  Iniciante   Postagens: 0

pessoal!
Fiz meu cadastro hoje, este é meu primeiro post, então olá a todos e muito obrigado pela oportunidade de utilizar o espaço!

Bom, estou com um problemão:
XOOPS 2.0.16 - News 1.53 e Editores Wysiwyg.

Instalei o WAMP 1.7.0 e logo levantei o XOOPS 2.0.16 - released 2006_11_17 que baixei do xoops.org. Instalei o lang-2.0.16-pt_BR.ISO-8859-1. Tudo beleza até aqui!

Coloquei o TEMA "thm_kris128" (o "Grassy") e beleza!

Instalei o "News 1.53" e o "News PT-BR language pack" baixados do XOOPS.instant-zero.com com.

Como o XOOPS 2.0.16 vem sem a pasta "xoopseditor" que fioca em class/xoopseditor com os editores, instalei o "XoopsEditor Framework - xoopseditor 1.10" baixado de dev.xoops.org

Tentanto habilitar os editores para o módulo News como o FCK e Koivi, fui atrás e constatei que teria de modificar o aquivo "modules/news/includes/functions.php", colocando o local correto dos editores na função "news_getWysiwygForm".

Pois bem, em preferências do múdulo News, modificando para o FCKeditor, fui postar notícias e o editor carregou tudo tranquilo, escrevi a matéria e tudo, mas quando vou ler a notícia aparece somente o título, ou seja, o sistema não gravou a chamada e o notícia completa. Então mudei para utilizar o Koivi, e acontece o mesmo, mas com uma diferença: das duas telas de edição do Koivi, somente consigo escrever a chamada da notícia, porque o para escrever a notícia completa o Koivi nem habilita a edição.

Preciso muito saber o que acontece que as notícias não são gravadas!
Não sou um excelente programador em PHP, vou até os meus limites, e foi o que fiz, mas não consegui fazer isso funcionar corretamente!

A nível de teste, fiz o mesmo com o News 1.44, da mesma forma e nada deu certo também!

Se alguém puder me ajudar nisso, ficarei MUITO grato, porque estou me quebrando para fazer isso funcionar!

Obrigado pessoal!
Obrigado pela atenção de todos...

glamenha  Iniciante   Postagens: 10

Olha só amigo,

Tive um problema semelhante ao seu, quebrei muito a cabeça e então resolvi instalar uma outra versão do XOOPS e o problema se foi.

Estou usando o XOOPS 2.2.4 + News 1.44 e aqui está funcionando tudo OK.

Esta versão já vem com a pasta class/xoopseditor tudo direitinho.

Você pode baixar a última versão estável no seguinte endereço:
https://xoops.net.br/modules/rmdp/down.php?id=1&sw=now&auto=1

Não sei se você está disposto a fazer isso, mas para evitar problemas acho que vale apena tentar.

Além do mais é sempre bom está com versões atualizadas e estáveis.

Boa sorte e bem-vindo ao mundo XOOPS.

Falow.

RUBENS  Iniciante   Postagens: 0

Glamenha!
Desde já agradeço muito sua prestatividade para com o meu problema!

Bom, há algum tempo venho usando exatamente isso:
XOOPS 2.2.4 com News 1.44, com os editores todos funcionando OK!

Mas desde o começo do ano venho acompanhando o desenvolvimento de módulos, temas e outras utilidade, e desde então venho tentando me aperfeiçoar no 2.0.X, porque pelo que vi parece mais estável, não só por ser indicado pelo xoops.org, mas eu usei e achei mais interessante mesmo! E também pela questão do desafio de poder instalar praticamente tudo do zero, porque no 2.0.16 - por exemplo - vem só com o esqueleto e você tem que ir instalando, adaptando, etc, fazendo a coisa toda funcionar, porém, é óbvio, é muito mais trabalhoso!

Uma das coisas que me chamou mais para o lado do 2.0.x - pode ser meio estranho até - foi quando eu fui instalar alguns temas do Kriss, como o Grassy por exemplo, e não consegui fazer funcionar no 2.2.x, aí me obriguei a ir para o 2.0.x e acabei achando bacana!

Sua sugestão do 2.2.4 com News 1.44 é o que tenho feito para "funcionar" as coisas, sem esquentar a cabeça, mas eu ficarei muito feliz quando conseguir fazer funcionar o 2.0.16 com News 1.53, com um tema baseado nos fantásticos CSS do Kriss (Grassy é um excelente tema base) e tudo mais!

Soa mais como desafio mesmo! E com isso uma evolução, porque teremos 2.2x e 2.0x funcionando ok, e podendo desvendar melhor ambas as vantagens e desvantagens!

Bom, é isso!
Agora vou lá me quebrar para tentar colocar no ar algo!

Observação: como exemplo, no inicio desse ano comecei a migrar o portal da empresa para a plataforma, e hoje temos algo bem melhor, e roda 2.2.4 com News 1.44 tudo perfeitinho! Porém, ao longo do seu funcionamento fui verificando que algumas coisas foram tornando-se necessárias, e muitas delas apontam para o 2.0.16, porque a parte de permissões e algumas outras funcionalidades parecem ser mais customizáveis no 2.0.16, e esse é um outro motivo pelo qual me faz ver esta versão como favorita hoje!
Por exemplo: hoje, nosso portal possui várias pessoas alimentando-o com informações! Não consigo fazer com que o pessoal que publica notícias apague, aprove as que ficam em standby, e outras coisas, sem que eles entrem na administração do portal! Mas isso é apenas um pequeno exemplo!

Bom, acho que já escrevi demais! Fico no aguardo.

Abraços

glamenha  Iniciante   Postagens: 10

Fala mano!

Estava dando uma olhada na rede e vi alguns comentários sobre essas versões do XOOPS. A galera fala bem do XOOPS 2.0.16

Eu ainda não instalei essa versão, mas teu comentário me deixou curioso.

Já baixei a versão 2.0.16. Vou instalar e trabalhar com ela para vê o que dá.

Olhando direitinho, quebrando a cabeça você aprende mais e entende melhor o que está acontecendo.

Bem, vou fazer meus testes e depois volto a postar sobre essa experiência.

Falow!

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 7 visitantes neste momento... (1 na seção Fóruns)

Associados: 0
Anônimos: 7

outros...

Banner XOOPS Cube