Problemas com Email

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
joelbrito  Iniciante   Postagens: 7

Ola.
Eu tou a tentar por a funcionar o email no meu portal XOOPS.
Ao enviar diz:

Erros.
Language string failed estou load: connect_host.
Não foi possível enviar e-mail para joelbrito.

Sending message completed.

Estou a utilizar o SMTP do Gmail. já alterei a porta mas não dá mm assim.
Alguém me pode ajudar?
Obrigado.

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

JOELBRITO, e já tentei utilizar o Gmail a pouco tempo atras, mais me parece que ele precisa de uma autenticação diferente da autenticação, que esta no XOOPS.
No meu eu uso o Yahoo e funciona muito bem.

niveamelo  Iniciante   Postagens: 2


Como faço para configurar o meu portal para que o formulário de "contato" me envie um email?

As configurações de email estão assim:

Email do remetente: niveamelo@yahoo.com.br
Nome e utilizador do remetente: niveamelo.
Método de envio: PHP mail()
Caminho do sendmail: /usr/sbin.

Os outros campos estão em branco.

Do jeito que está, ao ser preenchido o formulário de "contato" (que eu desabilitei para visitantes por enquanto), retorna "mensagem enviada", mas não recebo nem no meu email do yahoo, nem na caixa de entrada da área de administração.

Alguém pode me ajudar?

Antecipadamente grata, Nivea.

joelbrito  Iniciante   Postagens: 7

Ok. Mas eu estava a procura de um email grátis e o Yahoo só dá se fizer um upgrade da conta. Obrigado na mesma.

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

joelbrito, você ainda não é do Brasil ou é, porque no Brasil ainda é gratuito para este tipo de configuração, @yahoo.com.br se você ainda não tem estea terminação, tipo @yahoo.com me parece que é cobrado mesmo. Faça o seguinte abra o mail do yahoo e depois clique em Brasil (isto se não daqui), e faça um novo cadastro.

niveamelo sua configuração deve ser deste jeito:

email do remetente: niveamelo@yahoo.com.br

Nome e utilizador do remetente: niveamelo.

Método de envio: SMTPAUTH

Servidor(es) SMTP : smtp.mail.yahoo.com.br

Nome de utilizador do SMTPAuth : niveamelo.

Senha do SMTPAuth : *******


Depois que atualizar faça um teste como se tive-se esquecido sua senha e veja se funciona.

niveamelo  Iniciante   Postagens: 2

ArtsGeral.

Primeiramente muito grata pela ajuda, valeu mesmo.

Vi no tópico acima que você usa o Yahoomail também, isso me dá mais esperança de que o problema possa ser resolvido.

Infelizmente deve ter havido algum mal entendido da minha parte, porque ainda não está enviando mensagens.

Veja, coloquei exatamente assim:

Configuração do e-mail.

- E-mail do remetente: niveamelo2000@yahoo.com.br

(é o email verdadeiro, no tópico anterior eu esqueci o 2000).

- Nome do remetente: niveamelo.

- utilizador remetente de MP: niveamelo.

- Método de envio: SMTPAuth.

Caminho do sendmail: (aqui já testei de 2 jeitos: 1)deixando o que estava escrito no modo defaut [/usr/sbin] e 2)deixando o campo em branco).

- Servidor(es) SMTP: smtp.mail.yahoo.com.br

- Nome de utilizador do SMTPAuth: niveamelo2000

- Senha do SMTPAuth: minha senha do email do Yahoo.

Não entendi direito sua dica de testar fingindo que esqueci a senha, é para entrar como visitante no meu próprio portal e testar o envio do email, certo?

Muito grata pela atenção,
Abraços,
Nivea Melo

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

niveamelo
Se você usa um servidor de email externo, você ainda não usa o.

Caminho do sendmail: (aqui já testei de 2 jeitos: 1)deixando o que estava escrito no modo defaut [/usr/sbin] e 2)deixando o campo em branco)

Quanto a.
Não entendi direito sua dica de testar fingindo que esqueci a senha, é para entrar como visitante no meu próprio portal e testar o envio do email, certo?

É isso mesmo, é para ver se ele envia para seu email, a nova senha (no caso, é só para testar o envio do email)

Agora me lembrei o que esta acontecendo, no seu caso, por padrão o envio de email usa a porta 25 eo yahoo usa o 587, você terá que alterar 2 arquivos dentro de 1 pasta.
Na pasta html/class/mail/phpmailer tem 2 arquivos, você terá que trocar o conteudo de class.phpmailer.php e do class.smtp.php

No arquivo class.phpmailer.php vá na linha 162 ou procure.
var $Port = 25;
onde estiver o 25 troque por 587, depois salve.

No arquivo class.smtp.php vá na linha 30 ou procure.
var $SMTP_PORT = 25;
onde estiver o 25 troque por 587, depois salve.

Agora envie os 2 arquivo, de novo para o seu servidor de hospedagem, e faça o teste.

joelbrito  Iniciante   Postagens: 7

ArtsGeral. Não. Sou de Portugal. já criei uma conta no Yahoo br. E tambem alterei a porta para 587. Agora tenho um erro diferente:

Erros.
Language string failed estou load: from_failedjoelbrito85@gmail.com

O e-mail de confirmação foi enviado para joelbrito.

Isto quando faço o teste a fingir que esqueci a senha.
Diz que o email foi enviado mas não o chego a receber.

E este erro se tentar enviar o email aos utilizadores do portal:

Erros.
Language string failed estou load: from_failedjoelbrito8585@yahoo.com.br
Não foi possível enviar e-mail para joelbrito.

Sending message completed.

Tenho as seguintes configurações:

FROM address: joelbrito8585@yahoo.com.br
FROM name: joelbrito8585
FROM user: joelbrito.
Mail delivery method: SMTPAuth.
SMTP host(s) smtp.mail.yahoo.com.br
SMTPAuth username joelbrito8585
SMTPAuth password *****************

Se bem entendi as suas dicas a configuração está correta.

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

joelbrito olha eu não sei se é seu caso, mais fiz um teste no meu, mudando a senha, deu esse mesmo erro.

Language string failed estou load: from_faile

Reveja o seu codinome e senha

joelbrito  Iniciante   Postagens: 7

Esta tudo correcto e como escrevi em cima.
A senha esta correcta.

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

joelbrito
Então não sei o que pode ter acontecido, no meu funciona certinho, sem nenhum erro.

Qual versão do XOOPS você usa.

joelbrito  Iniciante   Postagens: 7

Tenho a versão 2.0.15.
Obrigado pelo seu tempo.
Abraço.

Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730

Agora que lembrei e procurei de novo este tópico.
No caso do joelbrito, talvez seja problema mesmo da hospedagem que não permite utilizar nada de envio de email, somente mediante a pagamento. Eu estava usando o freehostia.com e tinha dado pau nele, procurei uns outros e achai vários, e o que mais interessou foi o byethost.com fiz tudo certinho, fui fazer o teste de email, nada, fiz tudo que erra possivel fazer, e nada, cheguei a conclusão que é a hospedagem que trava a saida de email.
Pois aqueles que tiverem problemas de envio de email, pode ser algo haver mesmo com a hospedagem de não liberar a porta que é utilizada para enviar email mesmo sendo em SMTP.

Crazy  Iniciante   Postagens: 0

niveamelo escreveu:
Pessoal.

Como faço para configurar o meu portal para que o formulário de "contato" me envie um email?

As configurações de email estão assim:

Email do remetente: niveamelo@yahoo.com.br
Nome e utilizador do remetente: niveamelo.
Método de envio: PHP mail()
Caminho do sendmail: /usr/sbin.

Os outros campos estão em branco.

Do jeito que está, ao ser preenchido o formulário de "contato" (que eu desabilitei para visitantes por enquanto), retorna "mensagem enviada", mas não recebo nem no meu email do yahoo, nem na caixa de entrada da área de administração.

Alguém pode me ajudar?

Antecipadamente grata, Nivea.

O módulo envia o e-mail para o adminsitrador que esta registrado no campo:

E-mail do administrador, nas preferencias>>>Configurações gerais, no painel de admin.

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 29 visitantes neste momento... (20 na seção Fóruns)

Associados: 0
Anônimos: 29

outros...

Banner XOOPS Cube