Permissão de acesso

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Pessoal, publiquei a parte Institucional no meu portal a partir do tinycontent. Notei que tanto os utilizadores quanto os visitantes não tem permissão para acesso. Tentei alterar no módulo e não consegui. Procurei aqui no FAQ e não encontrei nada. Alguém sabe me dizer como faço para autorizar o acesso de visitantes e utilizadores ao conteúdo? Obrigado.

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

RESOLVIDO. Para quem tiver a curiosidade de saber, eu não havia acessado o módulo utilizadores >> Permissões dos utilizadores. Abraços.

jksig  Iniciante   Postagens: 0

não achei este módulo, aonde ele fica?
Só vi os seguintes módulos com utilizadores:

System Admin > Graduações.
System Admin > Editar associado.
System Admin > Localizar associados.
System Admin > Contatar associados.

Tem algum módulo especial?

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Encontrei aqui:
/modules/system/admin.php?fct=groups.

Em todo caso, você entra na administração, procura o menu superior. Lá vai aparecer Ações, Preferências, Módulos, Blocos, utilizadores e Ferramentas Diversas.

Em utilizadores há:
Localizar associados.
Contatar associados.
Graduações.
Grupos.

Foi aí que eu consegui desbloquear.

Qualquer dúvida escreva de novo.

Abraços.

jksig  Iniciante   Postagens: 0

Em grupos, permiti que visitantes tenham Permissões de acesso aos módulos, assim consigo ver todos os conteudos que fiz com o xt-conteudo.
Agora apareceu um endereço no MENU PRINCIPAL do XOOPS0-Conteudo, e não habilitei nada em blocos e também não aprece nada lá para eu tirar esse menu, como faço?

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Eu não uso o módulo XOOPS Conteúdo. Em todo caso, o XOOPS possui uma programação bem lógica e fácil de assimilar. Tente assim: Administração >> Preferências >> XOOPS Conteúdo (ou o nome que você lhe atribuiu) >> Preferência do módulo. Acredito que ali você poderá alterar os parâmetros adequadamente. Caso não funcione, vá em Módulos e procure alguma configuração específica do bloco XOOPS Conteúdo. E não se esqueça: para carregar mais rápido todas as alterações é aconselhável ir a Módulos >> Administração e atualizar o System Admin.
Espero ter ajudado porque também sou novato e não utilizo este módulo que você mencionou.
Abraços.

jksig  Iniciante   Postagens: 0

Nas preferencias do módilo só tem:
1.Usar Editor WYSIWYG?
2.Regra dos comentários.
3.Visitantes podem comentar?

Não entendi isso que você falou?

não funcione, vá em Módulos e procure alguma configuração específica do bloco XOOPS Conteúdo.

Na parte de módulos tem alguma configuração ou você disse no própio módulo (XT-conteudo)?

O engraçado é o seguinte, o LINK/MENU do módulo (XT-Conteudo) enta no meu menu principal, mas não configurei para que ele aparecesse, ou seja, já é uma pré-configuração dele, que quando eu autorizo os utilizador e visitantes terem acesso ao módulo ele já aparece no menu inicial sem eu mexer nas configurações de bloco.

Será que vou ter que tentar achar direto no código PHP dele, essa auto-configuração?

Não quero que o LINK/MENU fique disponivel para os visitantes, essa é a questão.

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Entendi sua preocupação. Também tenho áreas que não quero que fiquem acessíveis aos visitantes e outras aos utilizadores. Infelizmente só conheço estes caminhos para bloqueio. Em todo caso, eu não alteraria o código PHP. Note que o XOOPS é feito em blocos e módulos. A alteração e um deles, por menor que seja, pode complicar os demais e travar seu site. Seu problema é básico e apenas de configuração da permissão/bloqueio do acesso. Certamente deve estar em utilizadores >> Localizar associados >> Contatar associados >> Graduações >> Grupos, por ali. Foi nesse campo que consegui bloquear meu portal aos visitantes.
Vou alterar o prefixo deste tópico e colocar "aguardando". Acredito que assim mais alguém poderá lhe auxiliar. Também vou procuar o bloco que você utilizou e instalarei no meu portal. Assim que eu descobrir como ele funciona e se há alguma peculiaridade, aviso. Abraços.

jksig  Iniciante   Postagens: 0

Pedrotti,
Outra coisa que não coloquei, é que estou usando o xt-conteudo com o MultiMenu, masi acho que não faz diferença, naquele tutorial disponivel aqui não tem nada que explique, ou de uma ajuda.

Muito obrigado mesmo pelo seu suporte.
Jksig

João Barroca  Participativo De: Rio de Janeiro, Brasil  Postagens: 98


Neste tutorial [CLIQUE AQUI] não tem nada sobre multimenu e xt-conteudo?
@pedrotti: valeu pela ajuda!
Por favor deem um feedback sobre o tuto ok?
Abração,
João Barroca

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Completo seu material!
Obrigado! Agora, quando alguém perguntar vai ficar fácil ajudar a resolver.
Abraços.

João Barroca  Participativo De: Rio de Janeiro, Brasil  Postagens: 98



Acho que temos que fazer [atenção: o recado/pedido/súplica..rsrsrs... é para todo mundo! ] uma campanha internacional sobre o uso da ferramenta 'pesquisa' lá em cima a direita!

E creio também se cada um que resolvesse um problema mais cabeludo fizesse um mini-tutorial acho que ia facilitar para todos!

Abraços.[movido por [café]]

jksig  Iniciante   Postagens: 0

Amigos,
Com certeza fiz várias pesquisas e não só aqui, como em portais parceiros de vocês, porém esta minha duvida não se resolveu no tutorial, li inclusive o mega tutorial que explica tudo e com ele conseguio instalar o XOOPS, porém antes de dizer para eu ler o tuto, vejam se minha duvida está resolvida nele.
Tive outros problemas que consegui ersolver pela busca, para im ela é sabgrada Hehehe.
Abraço, Obrigado.

Ana Matte  Participativo De: Belo Horizonte - MG - Brasil  Postagens: 105

Jksig,
Fiquei curiosa: qual a versão do XOOPS você está utilizando? e qual a versão do XOOPS -Conteúdo? Pode estar havendo incompatibilidade entre elas. Alem disso, uma das diferenças fundamentais entre as duas últimas versões estaveis do XOOPS é justamente a administração. Mesmo que tenha resolvido seu problema - e eu agradeço se nos contar como - não deixe de nos informar sobre as versões, ok?
E, bom, nem sempre o amigo google e a ferramenta de busca ajudam, especialmente aos iniciantes, mas é importante que você nos conte que já tentou porque o que vigora em geral é a falta de vontade em utilizar esses recursos, assim a colocação do João Barroca era geral.
Conte conosco.
Acris

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

Meu caro jksig, notei que se há algo errado, provavelmente é relativo à configuração e não ao XOOPS.

A acris observou muito bem: "qual a versão do XOOPS você está utilizando?".

Há algum tempo antes você mencionou: "Será que vou ter que tentar achar direto no código PHP dele, essa auto-configuração?"

Está me parecendo que não é versão apenas, mas alteração de configuração também. O XOOPS é muito "redondinho". Qualquer alteração, por mais experiente que você seja, corre o risco de comprometer o restante sem você perceber.

Você já atualizou o sistema? Acredito que sim, mas a atualização dos módulos também é importante.

Quando elaborei meu primeiro portal a partir do XOOPS, tive problemas como você. Sabe o que fiz? Recomecei seguindo as instruções dos manuais. Se você seguiu todos os procedimentos ("Amigos,com certeza fiz várias pesquisas e não só aqui, como em portais parceiros de vocês, porém esta minha duvida não se resolveu no tutorial, li inclusive o mega tutorial que explica tudo e com ele conseguio instalar o XOOPS, porém antes de dizer para eu ler o tuto, vejam se minha duvida está resolvida nele.
Tive outros problemas que consegui ersolver pela busca, para im ela é sabgrada Hehehe.
Abraço, Obrigado."), acredito que a maior probabilidade é a de estar com problemas na configuração do equipamento ou na alteração dos códigos.

Sua dúvida aguçou a curiosidade de todos. Acredite, tem gente acompanhando o tópico e torcendo por um desfecho breve e positivo. Tudo isto ficou muito interessante!

João Barroca  Participativo De: Rio de Janeiro, Brasil  Postagens: 98

prezado jksig,
1. me pareceu que o tuto especifico do xt-conteudo e multimenu não havia sido encontrado. Dai a lembrança - respeitosa e bem-humorada - que um 'moderador' de fórum tem que fazer;
2. voltando ao que interessa: o problema continua? qual o problema mesmo?
Informe, como os demais amigos pediram, a versão do XOOPS, do módulo com problema e o PHP e confs de server que você está utilizandoJoão Barroca

jksig  Iniciante   Postagens: 0

EU resolvi o problema, usando o Menu do xt-conteudo, para outra coisa.
Não consegui tirar ele do meu Menu Principal, dai criei um foirmulário com o liaise, e usei para "tampar" o endereço do xt-conteudo.
Fiz o formulario e criei uma página no xt-conteudo com um código de redirecionamento para o endereço do formulario, e mudei o nome do xt-conteudo, na administração dos módulos.

Usei aquela frase antiga: "se não consegue vencê-lo, junte-se a ele"

Hehehehe.

Obrigado a todos o scomentários o pessoal daqui é 10, desculpe por qualquer coisa, é que estava injuriado com isso, depois de uma tarde perdida...dai hoje de manhã resolvi fazer isso.

Obrigado

William Pedrotti  Iniciante De: Valinhos - São Paulo - Brasil  Postagens: 15

jksig escreveu:
EU resolvi o problema, usando o Menu do xt-conteudo, para outra coisa.
Não consegui tirar ele do meu Menu Principal, dai criei um foirmulário com o liaise, e usei para "tampar" o endereço do xt-conteudo.
Fiz o formulario e criei uma página no xt-conteudo com um código de redirecionamento para o endereço do formulario, e mudei o nome do xt-conteudo, na administração dos módulos.

Usei aquela frase antiga: "se não consegue vencê-lo, junte-se a ele"

Hehehehe.

Obrigado a todos o scomentários o pessoal daqui é 10, desculpe por qualquer coisa, é que estava injuriado com isso, depois de uma tarde perdida...dai hoje de manhã resolvi fazer isso.

Obrigado

Parabéns! Não entendi absolutamente o que você fez, mas se resolveu, fico feliz em saber. Apenas por precaução, deixe tudo em "standby" por um tempo, só para garantir que não vai haver sobreposição ou conflito de módulos, prejudicando o restante do seu site.

Você deu um excelente exemplo de persistência! Merece meus sinceros ! Vai ganhar admiradores.

Quanto à sua frase, de que "se não consegue vencê-lo, junte-se a ele", vou te ensinar uma muito usada por advogados tributaristas: "Se você ainda não pode vencê-los, confunda-os!". Funciona para protelar o pagamento de impostos, mas não dá certo com informática, PHP ou XOOPS. Fique esperto com o seu "tapa-buraco".

Abraços.

Ana Matte  Participativo De: Belo Horizonte - MG - Brasil  Postagens: 105

Ótimo, muito bem. Mas continuo querendo saber as versões e se você está atento para questão da seguranca. Melhor prevenir.
Conta para gente as versões, quem sabe ainda haja outra solução ou um adendo a solução que você encontrou.
Obrigada,
Acris.

jksig escreveu:
EU resolvi o problema, usando o Menu do xt-conteudo, para outra coisa.
Não consegui tirar ele do meu Menu Principal, dai criei um foirmulário com o liaise, e usei para "tampar" o endereço do xt-conteudo.
Fiz o formulario e criei uma página no xt-conteudo com um código de redirecionamento para o endereço do formulario, e mudei o nome do xt-conteudo, na administração dos módulos.

Usei aquela frase antiga: "se não consegue vencê-lo, junte-se a ele"

Hehehehe.

Obrigado a todos o scomentários o pessoal daqui é 10, desculpe por qualquer coisa, é que estava injuriado com isso, depois de uma tarde perdida...dai hoje de manhã resolvi fazer isso.

Obrigado

João Barroca  Participativo De: Rio de Janeiro, Brasil  Postagens: 98


Tudo bem... tem horas que realmente dá vontade de jogar o dito cujo pela janela
Mas, voltando a vaca fria ... estou com o pedrotti e a acris - atenção que essa é velha! - igual a umbigo de vedete: totalmente por fora !
Falando serio: veh se recupera o passo a passo e o que você fez [faz um backup logo logo] porque essas coisas podem parar de funcionar na primeira atualização de sistema.
Abração e estamos ai!

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 36 visitantes neste momento... (17 na seção Fóruns)

Associados: 0
Anônimos: 36

outros...

Banner XOOPS Cube