Erro durante instalação da versão traduzida do XOOPS 2.05 16/10/2003

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
Anônimo    Postagens: 0

Não sei se fiz algo errado. Mas após sobreescrever todos os arquivos (exceto o mainfile.php) de uma instalação 2.05 em inglês (que estava funcionando normalmente), ao ir até o painel de administração, endereço preferências, qualquer uma das opções apresentam conteúdo em branco. Por exemplo, após clicar em configurações gerais fica: Preferências »» Configurações Gerais ... Sem mais nada, nenhum menu de opções para configurar =P.

O que fiz de errado?

PS.: Já limpei o cache te tentei uma reinstalação "por cima", inclusive sobreescrevendo o mainfile.php e nada das opções voltarem... =P.

Mikhail Miguel  Membro De: Angra dos Reis, RJ, Brasil  Postagens: 2466

E as permissões dos arquivos? experimente um "CHMOD -r html", por exemplo, só para ver se conserta.

Você também limpou o cache do "modelos_c"?

Mikhail Miguel    Postagens: 0

Isto foi sob o IIS no win XP pro... Não pode ser erro nos CHMODs.

(O conteúdo do modelos_c fora limpo também).

Mas já encontrei a solução:

Sobreescrevi os arquivos da versão tupiniquim pelos da versão em inglês de novo (exceto o mainfile.php), removi o conteúdo cache e ficou tudo OK. (o idioma eu havia mudado via SQL).

Está em português e funcional, mas analize a possibilidade de ter surgido algum problema em algum arquivo do sistema, porque foi muito estranho. =P

Rodrigo Ribeiro Neto  Ocasional De: Amparo - SP - Brasil  Postagens: 33

Aconteceu a mesma coisa comigo.

Mikhail Miguel  Membro De: Angra dos Reis, RJ, Brasil  Postagens: 2466

Ai, não... a coisa é reamente séria (não foi acidente então).

Gostaria de testar esses arquivos, mas estou mudando o portal para um novo servidor... além disso, ainda não consegui dormir.

Mikhail Miguel  Membro De: Angra dos Reis, RJ, Brasil  Postagens: 2466

Eu removi todos os diretórios "english" do XOOPS, menos o do install... será que foi isso? O XOOPS usa o inglês quando não encontra uma variável em português, ou coisa parecida...

Mikhail Miguel    Postagens: 0

Primeiro, porque você apagou os diretórios English? há alguma razão para isso? E se quisermos fazer uma tradução para o português de algum ítem, como teremos os parâmetros originais?

Eu sinceramente acredito que dois pontos num mesmo arquivo é demais, no caso de pt_utf8.

Eu, desculpem, mas renomeiei todos os diretórios para Brasileiro assim diminui pelo menos 60% dos problemas desses módulos do pacotão.

:(

Mikhail Miguel  Membro De: Angra dos Reis, RJ, Brasil  Postagens: 2466

Zura, não há problema desde que o xoopslang seja usado: ele usa o arquivo em inglês como original e só troca as variáveis, mantendo todo o resto da tradução exatamente como no original.

Você tem razão, os arquivos em inglês deveriam ser mantidos principalmente porque TODOS estão compatíveis com o xoopslang, ou seja, usam aspas duplas em vez de simples ( ' " )

Rodrigo Ribeiro Neto  Ocasional De: Amparo - SP - Brasil  Postagens: 33

Eu coloquei de volta os arquivos em inglês dos módulos e estou fazendo o upload para testar (ainda não sei como fazer os testes em minha maquina). Eu peguei os arquivos em inglês da versão "www.xoops.net.br-v2.0.5-pt-br-2003-10-08"... Vou ver se dá certo!

Obrigado!

Carlos Alberto  Ocasional De: Rio de Janeiro - Brasil  Postagens: 26

Deu o mesmo erro com migo...

Rodrigo Ribeiro Neto  Ocasional De: Amparo - SP - Brasil  Postagens: 33

Eu bem que tentei... Mas não deu mesmo... Como eu não manjo nada de programação, vou voltar a usar a versão "www.xoops.net.br-v2.0.5-pt-br-2003-10-08" mesmo.

Até!

Gilberto Galdino de Oliveira  Membro De: Guarulhos - São Paulo - Brasil  Postagens: 171

Você está fazendo testes locais ou está fazendo on-line?

Rodrigo Ribeiro Neto  Ocasional De: Amparo - SP - Brasil  Postagens: 33

gibaphp escreveu:
Você está fazendo testes locais ou está fazendo on-line ?

Estou fazendo testes online, porque ainda não consegui usar o EasyPHP... Aliás, se tiver um tutorial de como usar o EasyPHP eu agradeço!

Obrigado!

Mikhail Miguel  Membro De: Angra dos Reis, RJ, Brasil  Postagens: 2466

Também aconteceu comigo,... já troquei esse arquivo por um outro que também contem os diretórios "english"... Se alguém puder testar... seria legal...

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 38 visitantes neste momento... (22 na seção Fóruns)

Associados: 0
Anônimos: 38

outros...

Banner XOOPS Cube