Erro na área admin. do XOOPS

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
leomissao  Iniciante   Postagens: 0
<p><span>Olá pessoal.</span>

<span>Ao tentar acessar algumas áreas da admin. do XOOPS, tenho retorno da bendita tela branca.</span>

<span>Debug:</span></p><div class="xoopsCode">Fatal error: require_once() [function.require]: Failed opening required 'Smarty_Compiler.class.php'(include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/conta/public_html/class/smarty/Smarty.class.php on line 1454</div><p><span>
</span></p><p><span><span>Na linha 1454 do arquivo Smarty.class.php</span></span></p><div class="xoopsCode">require_once($this->compiler_file);</div><p><span>

<span>Alguma dica?</span>
</span></p>
leomissao  Iniciante   Postagens: 0
<p>Resolvido. Reenviado os arquivos do XOOPS.</p>
Andrax  Ocasional   Postagens: 27
Demorei demais de responder.

já tentou reenviar os arquivos?

Talvez o arquivo esteja corrompido!
leomissao  Iniciante   Postagens: 0
O intrigante é que estava funcionando tudo normal. Pergunta-se aos universitários:

Como estes arquivos corromperam-se sozinhos?

Obrigado camarada.
Andrax  Ocasional   Postagens: 27
Cara... as explicações são infinitas, mas a minha preferida é a de que um raio cósmico em sua rota se choca contra o núcleo de um dos átomos do disco e causa uma instabilidade eletromagnética que altera o bit do qual ele fazia parte e os bits mais próximos a sua volta de maneira totalmente aleatória!

É como dizem... Acontece.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
fiz uma transferência de um portal e agora estou com problemas nas datas.

por exemplo, uma notícia tem a data correta, aí caso eu a edite, ela fica com data de 1974, ou no caso dos meses fica um mês à frente, por exemplo uma notícia postada hoje cedo, fica com data normal, mas se a edito, ela fica com data de 01/01/1970.

E no módulo Soapbox, mesmo estando autorizado para os artigos dos colunistas serem aprovados imediatamente, eles não são aprovados, e se tento editar eles ficam com o mês de maio, ao invés de agora que é março. E sempre ficam offline.

O erro parece estar em alguma parte do system. Vou ligar o debug, e postar aqui, caso alguém já teve esse problema e saiba responder antes de eu postar o debug, fique à vontade. Agradeço antecipadamente!

Uso o última versão XOOPS 2.5.4. baixada aqui

O News ainda estou usando o 1.66

e Soapbox 1.51. indicado pelo XOOPS.

O apache e PHP são as [últimas versões)

Hospedagem Linux.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
Debug:

Queries 0.000091 - SET NAMES 'utf8'0.000053 - SET SQL_BIG_SELECTS = 1 0.000367 - SELECT * FROM config WHERE (conf_modid = '0'AND conf_catid = '1') ORDER BY conf_order ASC 0.000254 - SELECT sess_data, sess_ip FROM session WHERE sess_id = '0b247260d0df5c4a156a04f17d012db0'0.000099 - SELECT * FROM users WHERE uid = '1'0.000076 - SELECT * FROM modules WHERE dirname = 'system'0.000562 - SELECT * FROM config WHERE (conf_modid = '1') ORDER BY conf_order ASC 0.000501 - SELECT * FROM config WHERE (conf_modid = '0'AND conf_catid = '3') ORDER BY conf_order ASC 0.000206 - SELECT * FROM modules WHERE (hasadmin = '1'AND isactive = '1') ORDER BY weight ASC, mid ASC 0.000139 - SELECT * FROM modules WHERE dirname = 'news'0.000412 - SELECT * FROM config WHERE (conf_modid = '2') ORDER BY conf_order ASC 0.000096 - SELECT DISTINCT c.* FROM imagecategory c LEFT JOIN group_permission l ON l.gperm_itemid=c.imgcat_id WHERE (l.gperm_name = 'imgcat_read'OR l.gperm_name = 'imgcat_write') AND (imgcat_display = '1') ORDER BY imgcat_weight, imgcat_id ASC 0.000214 - SELECT * FROM modules WHERE dirname = 'soapbox'0.000106 - SELECT author FROM sbcolumns WHERE author = 1 0.000415 - SELECT * FROM config WHERE (conf_modid = '4') ORDER BY conf_order ASC 0.000088 - SELECT columnID, name FROM sbcolumns ORDER BY weight 0.000087 - SELECT * FROM modules WHERE dirname = 'protector'0.000080 - SELECT * FROM modules WHERE mid = 5 0.000137 - SELECT * FROM modules WHERE dirname = 'rw_banner'0.000194 - SELECT * FROM configcategory Total: 20
Andrax  Ocasional   Postagens: 27
Aparentemente o problema com as datas é gerado por conta da versão do PHP, estou investigando uma solução e assim que a tiver posto aqui.

Quanto ao problema do Soapbox, bom é um módulo bem antigo e é possível que algumas coisas não funcionem nas versões mais recentes do PHP e do XOOPS... talvez o ideal seja buscar um módulo alternativo para substituí-lo e que atenda a sua necessidade

As linhas do debug apresentadas são referentes as querys do banco... não ajudam muito a identificar erros(já que pelo visto o erro não está no banco), clique no endereço Erro, para que o debug mostre os erros do sistema.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
no debug, erros, não consta nada.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
Agora aparece os seguintes erros:

Informação: Constant _MB_SB_SELECTCOL already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 36 Informação: Constant _MB_SB_ARTSTOSHOW already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 37 Informação: Constant _MB_SB_SHOWDATE already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 38 Informação: Constant _MB_SB_SHOWBYLINE already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 39 Informação: Constant _MB_SB_SHOWSTATS already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 40 Informação: Constant _MB_SB_TEMPLATE already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 41 Informação: Constant _MB_SB_WEIGHT already defined arquivo /modules/soapbox/language/pt_utf8/blocks.php linha 44
deda  Iniciante   Postagens: 2
Observei o mesmo problema com as datas ao utilizar o módulo News com o XOOPS 2.5.4 ~só insere a data correta se for no formato mês/dia/ano.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
Já publiquei em outros post, o problema acontece como Soapbox e o News 1.67RC1. QUando editamos uma postagem, ela fica com dia e mês invertidos. E fica indisponível.
Andrax  Ocasional   Postagens: 27
já estou ciente do problema, mas tive pouco tempo nos últimos dias, devo aprofundar as investigações para encontrar uma solução nos próximos dias.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
Caro camarada, não sei se o que percebi ajuda em algo.

Mas é o seguinte, tanto no módulo Soapbox, como no News, acontecem isso:

Quando eu posto um texto, ele fica correto.

Mas se eu tentar reeditá-lo, alterando ou não sua data ele fica com problemas, desaparece, ou fica offline ou em modo de espera.

Percebi que as datas nossas do Brasil em DD/MM/AAAA ao serem editadas só ficam corretas se colocar ficam corretas se colocarmos no texto editado desse jeito independente de onde esteja escrito que é dia mês ou ano.

fica correto o texto editado se colocamos a data assim:

MM/DD/AA

Isso mesmo além de o mês e dia estarem invertidos como o tipo estadunidense, o ano se reduz a dois dígitos AA.

Se colocarmo o ano inteiro AAAA, fica marcado como 1969 ou 1970, por aí.
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Será que isto não envolve os arquivos de tradução do XOOPS? estava com um problema em um determinado módulo e lá na nave mãe me disseram para dar uma olhada nessa thread, não seria a mesma coisa?

http://www.frxoops.org/modules/newbb/viewtopic.php?topic_id=35445&post_id=218518#forumpost218518
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
ALELUIA!

Estou testando aqui, e até agora deu certo!

Vou ver tudo direito e aviso por enquanto a modificação resolveu o problema no News e Soapbox!

Muito obrigado Angelo.
Alex Bezerra  Participativo De: Betim - MG  Postagens: 134
Pronto testei a solução do problema das datas no XOOPS 2.5.4 está aqui

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 31 visitantes neste momento... (17 na seção Fóruns)

Associados: 0
Anônimos: 31

outros...

Banner XOOPS Cube