Traduzindo módulos rapidamente com xtransam

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Salve! Nessa micro vídeo aula eu mostro como se traduz um módulo automaticamente com o módulo xtransam. Módulo enviado para mim pelo nosso amigo Daven. Assistam a vídeo aula aqui: [youtube=425, 350]http://www.youtube.com/watch?v=aRiMkq5671Y[/youtube]

Baixem o módulo aqui: http://bit.ly/ohsxKt

Espero que gostem! Ps.: está sem voz, mais não precisa
Daven  Participativo De: Imperatriz MA  Postagens: 140
Opa angelo, que bom que você conseguiu bota para funcionar velho, amanha eu testo ele... você conseguiu tanto pela forma automatica como pela manual?

o antigo tópico pode ser visto AQUI..
Andrax  Ocasional   Postagens: 27
Obrigado, pelo video!

Só vale lembrar que a tradução do Google nem sempre é correta, mas sem dúvida deve ajudar no processo de tradução dos módulo, as quais inevitavelmente necessitarão de revisão posterior.

Quando tiver tempo Farei mais uns testes nesse módulo.
Daven  Participativo De: Imperatriz MA  Postagens: 140
Opa Angelo.

você traduziu ele do zero ou aproveitou a meia boca que fiz?

fez alguma correção tb? só para saber se o módulo que você postou tem algo diferente do que tenho aqui(o que eu te mandei)
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Daven, não trabalhei muito na tradução dele nao, só alterei o nome dele mesmo porque tenho problemas em alterar nome original do módulo, mais é coisa minha mesmo. Quanto ao módulo, está exatamente como você me mandou.

estou ciente disto, tanto que o módulo tem outra parte, que esqueci de mostrar, que seria justamente para ajustes na tradução, vou mostrar isso em outra vídeo aula a noite =P, pois no ápice do heavy metal me esqueci. Lembrando que dependendo do tamanho do módulo, a terceira parte vai demorar um bocado.
Daven  Participativo De: Imperatriz MA  Postagens: 140
Pois é Angelo, estou começando a achar que é pessoal^^

o que não está acontecendo comigo é o seguinte.

quando clica em "traduzir automaticamente", aparece a mensagem de "tradução automática completa (favor checar)"

só que a opção "Construir arquivo base" não aparece, na verdade eu nunca tinha visto essa opção, por isso nunca consegui.

o que será que está acontecendo?

segue os erros na página:
 Informação: Constant _CHARSET already defined arquivo /language/pt_utf8/global.php linha 225 Informação: Constant _MI_XTRANSAM_ADMENU1 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 35 Informação: Constant _MI_XTRANSAM_ADMENU2 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 36 Informação: Constant _MI_XTRANSAM_ADMENU3 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 37 Informação: Undefined variable: i arquivo /modules/xtransam/xoops_version.php linha 89 Informação: Use of undefined constant _MI_PUBLISHER_ARCHIVE__DSC - assumed '_MI_PUBLISHER_ARCHIVE__DSC'arquivo /modules/publisher/xoops_version.php linha 306 Informação: Undefined variable: i arquivo /modules/xtransam/xoops_version.php linha 89 Informação: Constant _MI_NAMEDISPLAY already defined arquivo /modules/news/language/pt_utf8/modinfo.php linha 40 Informação: Constant _MI_UPLOADFILESIZE already defined arquivo /modules/news/language/pt_utf8/modinfo.php linha 43 Informação: Constant _MI_UPLOADFILESIZE_DESC already defined arquivo /modules/news/language/pt_utf8/modinfo.php linha 58 


Configurações: Versão do XOOPS XOOPS 2.5.0 Versão do PHP 5.2.17 Versão do MySQL 5.1.49-gpl-log API do Servidor apache2handler OS Linux safe_mode Off register_globals Off magic_quotes_gpc Off allow_url_fopen Off fsockopen On post_max_size 64M max_input_time 60 output_buffering 4096 max_execution_time 60 memory_limit 96M file_uploads On upload_max_filesize 64M
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
A maioria é de constantes das linguagens, isso não vai impedir o funcionamento do módulo, estranho. Já tentou uma nova instalação para ver se de repente não é alguma coisa na tua instalação atual?
Edison Pinho  Iniciante   Postagens: 9
Tenho problemas quando o XOOPS2.5.0 está na configuração "ISO" ou "portuguese", acho que esse módulo é só para codificação "UTF8" ou "pt_utf8", por favor me diga se estou errado.

@Angelo, parabéns os vídeos estão perfeitos.
Daven  Participativo De: Imperatriz MA  Postagens: 140
Pois e... eu estava tentando no meu portal msm, nele não rola de fazer uma nova instalação.

ai, eu tentei fazer uma instalação local com o XAMPP lite 1.7.1

tudo instalado, quando clico no "traduzir automaticamente" ele fica carregando e não vai para lugar nenhum.

só aparece essa msg:
 Já se passaram quase 30 segundos de execução! 

Esta é a inicialização do temporizador número 31 O processo será concluído em breve!
esse numero "31" já chegou até 311 quando cancelei

não sei... realmente

os únicos erros são esses:

 Informação: Constant _CHARSET already defined arquivo /language/pt_utf8/global.php linha 225 Informação: Constant _MI_XTRANSAM_ADMENU1 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 35 Informação: Constant _MI_XTRANSAM_ADMENU2 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 36 Informação: Constant _MI_XTRANSAM_ADMENU3 already defined arquivo /modules/xtransam/language/pt_utf8/modinfo.php linha 37 Informação: Undefined variable: i arquivo /modules/xtransam/xoops_version.php linha 144 Informação: Undefined variable: i arquivo /modules/xtransam/xoops_version.php linha 144 


<edit> Só para constar, atualizei meu portal de 2.5.0 para 2.5.1a e o problema continuou. <edit>
Daven  Participativo De: Imperatriz MA  Postagens: 140
Ninguém mais com esse problema?

alguém testou? funcionou?

Angelo seu PHP é 5.3 né? Será que é isso?
Edison Pinho  Iniciante   Postagens: 9
Edison Pinho  Iniciante   Postagens: 9
Achei essa API free, talvez alguém saiba como fazer usando ela, mesmo sendo da MS, é bom ver se funciona, pois o Google está ficando igual MS cobrando o serviço que era gratuito e MS está compartilhando de graça, até agora.
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Pois é, justo agora Daven que aprendemos a usar o módulo. No mais espero boas notícias quanto ao uso de uma outra alternativa pois este módulo é muito útil, Google danadinha, ferrando com todo mundo

Pelo que vi até agora a ferramenta vai funcionar até dezembro, acabei de traduzir o extgallery 1.10, quem quiser traduzir módulos fácil aproveita porque essa é a hora
Daven  Participativo De: Imperatriz MA  Postagens: 140
Verdade, mas pelo que se conhece do trabalho do wishcraft, ele logo dá um jeito nessa "barreira" e manda um up do módulo com uma nova api.

bom... eu nunca consegui botar esse módulo para funcionar^^. frustration mode [on]^^

mas.

quem sabe com esse up eu não consiga usar o bendito módulo
Daven  Participativo De: Imperatriz MA  Postagens: 140
Bem... só para avisar o povo saiu a nova versão do módulo

xTransam 1.16

e continuo sem conseguir usar o gente boa ai.

mas para quem está usando... ^^
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Complicado heim Daven, ele está de marcação com você.

Eu estive usando ele no fim de semana e foi acrescentado outro API para tradução, nas preferências do módulo você pode escolher se quer usar o Google translator API (exige sua chave da API) ou outro, no caso o MyMemory Translation.

Teste com os dois, com o Google tradutor é sem futuro, porque ele limita muito a quantidade de texto e fica inviável traduzir, daí você altera o tipo de tradução nas preferências para "MyMemory Translation" que ele traduz, mais tem um porém, quando eu clico em traduzir automaticamente ele demora lá o tempo dele e diz ter terminado a tradução, ai se vou em gerenciar a tradução aparece o texto lá bonitinho e tudo, mais quando construo o arquivo base, este, vem em ingles ainda, pense numa marmota, o que poderá estar acontecendo.
Daven  Participativo De: Imperatriz MA  Postagens: 140
Pois é Angelo, o problema é que a opção "COnstruir Arquivo base" não aparece para mim, no passo anterior ele termina e continua a mesmo opção, sem aparecer a opção de construção.
Angelo Rocha  Membro De: Fortaleza - CE - Brasil  Postagens: 613
Saiu o 1.18 com a api do BING(eu nem sabia que tinha :P) Link: http://bin.chronolabs.coop/xoops2.5_xtransam_1.18.zip
Edison Pinho  Iniciante   Postagens: 9
ótimo aqui para mim continua sem gravar no arquivo destino, falei para o wishcraft e até agora ele não me respondeu.

Opa, nem foi precisou me responder, já foi lançando a próxima versão xtransam_1.19, já baixei e irei testar para ver se o problema foi resolvido.
Edison Pinho  Iniciante   Postagens: 9
Está funcionando quase que perfeito a versão xoops2.5_xtransam_1.20.zip eu já consegui traduzir parcial o xtransam usando o MyMemory em Preferência e depois fazendo o processo normal para traduzir, como já explicado pelo Angelo, cuidado com a barra \ e as ASPAS elas causam alguns erros, você utiliza o Edit/Manage Translation para corrigi-los.

Lembrando em: A) Quem será traduzido e para qual liguagem e a tradução. B) Do Translation 1º Auto Translate -> Traduzir Automatico 2º Build File Base -> Construir Base de Dados de Arquivo 3º Edit/Manage Translation XOOPS - > Editar

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 17 visitantes neste momento... (10 na seção Fóruns)

Associados: 0
Anônimos: 17

outros...

Banner XOOPS Cube