Problemas no registro de usuários

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
omarvix  Iniciante   Postagens: 0
Preciso de ajuda para resolver esse problema.

O sistema de registro de novos usuários não permite a inscrição. Toda vez que tento realizar a inscrição de um usuários recebo a mensagem: "O processo expirou, por favor, volte a tentar de novo".

Estou utilizando o XOOPS 2.5 e o módulo "User Profile 1.6".

Alguém tem uma dica?

Essas são as informações "Na visão geral do sistema" Versão do XOOPS XOOPS 2.5.0 Versão do PHP 5.2.14 Versão do MySQL 5.0.92-community-log API do Servidor apache2handler OS Linux safe_mode Off register_globals Off magic_quotes_gpc On allow_url_fopen On fsockopen On post_max_size 8M max_input_time 60 output_buffering max_execution_time 30 memory_limit 256M file_uploads On upload_max_filesize 50M
omarvix  Iniciante   Postagens: 0
Ainda aguardando ajuda.
Andrax  Ocasional   Postagens: 27
Pelo que entendi o problema é que como o cadastro é muito grande acaba por expirar a sessão... não sei se tem como configurar essa sessão(provavelmente não!), mas acredito que existe uma alternativa... as versões mais recentes do XOOPS permitem que o cadastro seja dividido em etapas, como seu cadastro é um pouco grande acho que dividindo ele em 2 etapas deve resolver o seu problema.

Não tive tempo de testar.
omarvix  Iniciante   Postagens: 0
já tinha testado essa alternativa. Deixei somente o básico:

Nome de Usuário *

E-mail *

Senha *

Verificar senha *

Nome Completo *

O resto como complementar, não deu certo, continuei a receber a mensagem: "O processo expirou, por favor, volte a tentar de novo".

Retirei o mome completo do básico e coloquei em complementar. Nno momento de enviar ele avisa que "O processo expirou, por favor, volte a tentar de novo".

No portal do XOOPS Brasil não tem esse problema. Qual Versão do profile vocês estão utilizando?
leomissao  Iniciante   Postagens: 0
pode compartilhar o endereço do portal para fazer um teste?
omarvix  Iniciante   Postagens: 0
O portal ainda não está pronto, faltam apenas duas coisas. Usar o Publisher para compartilhar os artigos e o registro de usuários para permitir subscrição na home page.

Esse é o endereço, ainda provisório: http://proteoria.org/xoops/ Depois coloco ele na raiz.

Qualquer ajuda é bem-vinda.
leomissao  Iniciante   Postagens: 0
Se observar na admin. do XOOPS, fiz dois cadastros: leomissao e Angelo. Ambos corretamente no sistema operacional Linux Mint.

Tentei fazer o cadastro no Windows e não obtive sucesso, ocorre o erro citado por você.

O intrigante é que o erro só ocorre no Windows, logo acredito que não seja um problema de expiração de sessão que foi citado pelo camarada.(como ele não testou, não encontrou o erro)

Outra coisa que observei é que o cadastro não é muito grande não. Veja o cadastro do portal APH Cursos
leomissao  Iniciante   Postagens: 0
Mesmo exibindo a mensagem que expirou o cadastro foi realizado(isso no windows, no linux recebo a confirmação de cadastro pedindo a confirmação por e-mail).

O problema é que se o visitante for realizar o cadastro e ver a sessão foi expirada ele vai pensar que não foi realizado o cadastro, e depois ficará espantado a ver uma mensagem em seu e-mail pedindo a confirmação de cadastro que teoricamente não foi realizado, isso pode deixar o visitante temeroso suspeitando que seja uma mensagem com conteúdo perigoso(virus)

Já tentou reinstalar o XOOPS, ou reinstalar o módulo?
omarvix  Iniciante   Postagens: 0
Vou reinstalar o profile. Não tenho ele aqui comigo, fazia download no XOOPS-BR, mas ele está em manutenção. Você tem a última versão em português desses módulo disponível?
Edson Oliveira  Membro De: R. Liberdade, Centro, Atibaia - São Paulo, BR   Postagens: 730
O módulo profile é nativo do XOOPS, ele já vem no pacote do core do XOOPS.
omarvix  Iniciante   Postagens: 0
Estou utilizando o módulo "User Profile 1.6". Nele tem escolher os campos que devem ser preenchidos. O profile nativo não dá opções, por isso fiz opção pelo módulo, mas infelizmente ele está apresentando esses problemas e sem esse módulo não consigo colocar o portal definitivamente acessível para os usuários/visitantes.

Agradeço a ajuda.
leomissao  Iniciante   Postagens: 0
Professor os campos que acrescentei no formulário de registro que postei o endereço no tópico, foram criados com o profile que vem com o XOOPS.(XOOPS 2.5.1a)
omarvix  Iniciante   Postagens: 0
Estou utilizando o XOOPS 2.5, entrei no administrador mas não encontrei o local que é possível editar o profile, nativo do XOOPS. Essa função é apenas do 2.5.1? Os anteriores também permitem essa edição do formulário de subscrição de novos usuários?
omarvix  Iniciante   Postagens: 0
Instalei o módulo "User profile 1.7", mas o captcha está com problemas, Algumas vezes ele não aparece em outras quando peço para atualizar o código ele informa: "Input error: Invalid referer". Tem alguma configuração especial para que ele atualizar?
leomissao  Iniciante   Postagens: 0
O módulo que uso no portal que lhe mostrei é o profile 1.6.

Porque o senhor não atualiza o XOOPS para versão 2.5.1a(que é a versão mais atual). Infelizmente, não tenho o XOOPS 2.5 aqui para fazer o teste com o profile 1.6 nele, mas acredito que ele funcione sem problemas no XOOPS 2.5.

Este erro pode estar relacionado a algum arquivo corrompido na instalação do XOOPS, por isso sugeri a atualização.

Se precisar de ajuda na atualização é só dar um grito.
omarvix  Iniciante   Postagens: 0
Continuo com o problema no registro de usuários. Agora o portal está com o XOOPS 2.5.1a, mas nada mudou, ele continua a mandar a mensagem "O processo expirou, por favor, volte a tentar de novo". Deixei apenas o básico do básico e nada, o problema persiste. Desinstalei o profile para usar o registro do próprio XOOPS, nesse formato o problema é que não tem o captcha. Mesmo assim na hora de fazer o registro ele manda uma mensagem dizendo "Valid token expired".

O que pode ser?
leomissao  Iniciante   Postagens: 0
Veja a mensagem que lhe enviei.
omarvix  Iniciante   Postagens: 0
Problema resolvido. Era uma questão de configuração. Deixei o portal sem o módulo profile, para ele apresentar o formulário básico do XOOPS. Na hora do registro começou a aparecer a mensagem: "Valid token expired". Fiz uma busca pelo Google e encontrei uma solução no http://xoopsbr.orgfree.com/modules/d3forum/index.php?topic_id=3575. É uma solução dada pelo camarada.

não sei se isso resolve, mas citando o uma das respostas do XOOPS.org http://www.xoops.org/modules/newbb/viewtopic.php?post_id=257599#forumpost257599 esta traduzido via Google Citando:

Isso pode acontecer quando você define seu costume sessão tempo demasiado baixo. Fiz um presente antes. Se você está familiarizado com phpMyAdmin, é fácil de corrigir. Basta abrir o banco de dados no phpMyAdmin você, procure o _config tabela e olhar para a coluna conf_name valor de session_expire. Por padrão, o conf_value está definido para 15. Encontrei com a experiência que você realmente não quer ir muito mais baixos do que ou você pode ter problemas, como você está tendo agora.

Basta definir a conf_value de volta para 15 e você deve estar OK.

Instalei de novo o profile e modiquei os campos como necessito, deu certo. O portal nessa semana será compartilhado.

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 27 visitantes neste momento... (15 na seção Fóruns)

Associados: 0
Anônimos: 27

outros...

Banner XOOPS Cube