Problema para enviar e-mail

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
andunno  Iniciante   Postagens: 9

Boa tarde pessoal.
Estou, de novo, precisando da ajuda dos experts em XOOPS.

Estou utilizando o XOOPS 2.0.17 e instalei o Liaise 1.26 porém não estou conseguindo enviar e-mail através do formulário. O formulário está configurado para enviar o e-mail para a conta do admin (que é um endereço interno da empresa).

Se eu configurar o XOOPS para utilizar 'PHP mail()', ele aparece a seguinte mensagem:

'Could not instantiate mail function.'

Quando configuro para utilizar 'SMTP' ou 'SMTPAuth', aparece a seguinte mensagem:

'SMTP Error: Could not connect estou SMTP host.'

Já se eu configuro para utilizar 'sendmail', aparentemente a mensagem parece que foi enviada porém eu não a recebo.

Alguém pode me dar uma luz?

Andrax  Ocasional   Postagens: 27

anduno... , dá uma olhada nesse 2 tópicos e vê se resolve... (dicas da Gisa_Iagami em outro tópico!)
XOOPS e compativel com a função ultramail()
Problemas com o email.

Falows... T+!

andunno  Iniciante   Postagens: 9

Caro Luiz Carlos,

Olhei os tópicos que você recomendou mas ainda não consegui fazer o XOOPS enviar e-mail.

Como ainda estou testando o XOOPS eu o instalei em uma máquina virtual Linux.
Na minha rede eu possuo um servidor de e-mail onde nas configurações de SMTP eu configurei esse meu servidor.
Analisando os logs do meu firewall, verifiquei que quando eu tento enviar um e-mail, a minha máquina virtual consulta o meu servidor DNS, que por sinal é o mesmo servidor de e-mail, porém não conecta na porta 25 do servidor. Não é regra de firewall porque eu tenho uma regra liberando o acesso de toda a minha rede interna na porta 25 do servidor de e-mail.

Você teria mais alguma ideia de como eu consigo resolver esse problema?

andunno  Iniciante   Postagens: 9

Finalmente consegui enviar e-mail!

É a maldita mania de esquecer de olhar os logs... Olhando o /var/log/maillog verifiquei que o XOOPS estava usando o usuário 'apache' para enviar o e-mail e que por causa disso estava apresentando erro de permissão de acesso na pasta /var/spool/mqueue (pensei que ele estive usando o /var/spool/clientmqueue).

Depois de configurar a permissão dessa pasta consegui enviar e-mail utilizando tanto o 'PHP mail()' quanto o 'sendmail'.
Só estou achando estranho não estar funcionando o 'SMTP' e o 'SMTPAuth'. Mas pelo agora estou conseguindo enviar e-mail no XOOPS.

Obrigado pela ajuda!

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 31 visitantes neste momento... (19 na seção Fóruns)

Associados: 0
Anônimos: 31

outros...

Banner XOOPS Cube