XOOPS utilizando excessivamente o MySQL e o processador

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
Aaraon Thomas  Iniciante   Postagens: 2

Salve gente!

O data center me suspendeu pois, segundo eles:
"seu portal estava utilizando 12% do processador hoje, com picos de 17%. Quando que os portais só podem utilizar 3% do processador."

O que pode ter causado isso? Eu não tenho chats nem nada que possa causar isso.
Eu tenho downloads, notícias, artigos, galeria de imagens, parcerias, contato, links e só.

Será que alguém teria alguma ideia? Ou será que simplesmente entrou gente demais na minha página? Porque sim, isso pode ter ocorrido.

Desde já agradeço!

costacafj  Iniciante   Postagens: 0

Dê uma olhada neste post. Te ajudará:

Site suspenso por causa do SUPER USO

wilson  Iniciante   Postagens: 0

@ aaron.

Coloca ae o endereço do host prá gente fazer uma visitinha e elogiar

Estes caras são folgados pacas!
Qto de deram de tráfego?

Aaraon Thomas  Iniciante   Postagens: 2

Salve CostaFJ

Valeu pela ajuda. Infelizmente eu acho que, se tiver, tenho um bloco com cache ativado e eu mesmo não costumo mandar e-mail para os membros.
Isos que me preocupa, minha página tem uma média de 1000 a 1200 visitantes por dia. Não deveria dar isso até eu bater na casa do 8000, estou certo?
Bem, quando voltar eu vou procurar o que pode estar "sugando" o MSQL.
Eu tenho um fórum (bem mais sossegado do que a página) em IPB.

Outra coisa, será que criar e-mail nome@127.0.0.1 dá algum problema em SQL?

costacafj  Iniciante   Postagens: 0

Aaraon escreveu:
Salve CostaCafj.

Valeu pela ajuda. Infelizmente eu acho que, se tiver, tenho um bloco com cache ativado e eu mesmo não costumo mandar e-mail para os membros.
Isos que me preocupa, minha página tem uma média de 1000 a 1200 visitantes por dia. Não deveria dar isso até eu bater na casa do 8000, estou certo?
Bem, quando voltar eu vou procurar o que pode estar "sugando" o MSQL.
Eu tenho um fórum (bem mais sossegado do que a página) em IPB.

Outra coisa, será que criar e-mail nome@127.0.0.1 dá algum problema em SQL?

Eu estou com o Wilson. Acho que eles te deram pouco tráfego. Isso não deveria acontecer. Aqui no XOOPS não acontece! E olha que já estamos com mais de 1100 utilizadores.

Está certo que bo parte não entra junto, mas isso não é desculpa para eles.

Quanto ao email, isso não influencia em nada o portal (não deveria, pelo menos). O email é um pedaço do serviço meio que à parte da hospedagem do portal em si.

Aaraon Thomas  Iniciante   Postagens: 2

Salve Wilson.

Anota ai:
http://falerpg.com.br/

Mas eu não posso reclamar, a HostNacional http://hostnacional.com tem me dado uma baita mão e inclusive olha o que me mandou por e-mail:
"O seu script XOOPS está utilizando excessivamente o MySQL e o processador. Devido a isto sua conta foi suspensa, mas sendo realista e como gosto das coisas transparentes sem problema algum, acabei me desentendendo com meu suporte dos EUA, então imediatamente estou fazendo acertos em uma máquina dedicada onde só se encotnrará o seu site."

Mesmo assim, minha banda era de 5GB e eu poucas vezes passei dos 4GB. Por isso meu susto.

wilson  Iniciante   Postagens: 0

Tenho quase certeza que isto se deve a uma má configuração do server por parte deles, nacionais ou importados.

Fica o alerta para futuros users que queiram hospedar seus portais por lá.

Obrigado pelas infos, aaron.

Aaraon Thomas  Iniciante   Postagens: 2

Tenho quase certeza que isto se deve a uma má configuração do server por parte deles, nacionais ou importados.

Existe alguma dica preu passar para o cara do Host? Ele tem me dado uma mão e eu acho que, se eu tiver como dar umas dicas, seria uma gentilesa válida.

wilson  Iniciante   Postagens: 0

Acho que uma boa dica para ele que é do ramo, seria tentar descobrir como funcionam os servers de empresas do tipo localhost, digiweb, hcerto e etc.( estou falando isto sem pedantismo ou ironia)

Ou pedir para ele fazer um upagrade do plano de revenda dele junto aos servers(empresa) americanos.

O que pode estar ocorrendo aaron, é que o próprio plano dele possa ser muito restrito, apertadinho, rss.

Porque se não veja, teríamos uma verdadeira onda contrária a qualquer implementação de vários outros cms´s por vários hosts. E isto na verdade não acontece.

Agora uma super dica de alto nível técnico para melhorar a performance do server, eu não saberia te dizer não.

Alguém por ae pode contribuir com algo?

luiz henrique dos santos borges  Iniciante De: taquara -Rio de Janeiro - RJ  Postagens: 6

Eu estou com o Wilson. Acho que eles te deram pouco tráfego. Isso não deveria acontecer. Aqui no não acontece! E olha que já estamos com mais de 1100 utilizadores.

Está certo que bo parte não entra junto, mas isso não é desculpa para eles.

Quanto ao email, isso não influencia em nada o portal (não deveria, pelo menos). O email é um pedaço do serviço meio que à parte da hospedagem do portal em si.

Pessoal trabalho na HostNacional, assim como já havia passado por e-mail para o Aaraon, não é por problemas de tráfego de banda. Já que o portal dele algumas poucas vezes, consegue atingir os 4 GB. Já que seu contrato conosco é de 5 GB mensal, com margem de oscilação de mais 1 à 2 GBs para emergência como cota extra, que foi acertada.

Havendo algum problema do limite de banda estourar, entra em ação os 2 Gbs reservas.

Quanto ao e-mail, ele faz parte da hospedagem sim, entra como tráfego (pouco mas entra) e como espaço em disco. (HD)

luiz henrique dos santos borges  Iniciante De: taquara -Rio de Janeiro - RJ  Postagens: 6

Enviado por Wilson em 16/12/2004 17:48:23

Tenho quase certeza que isto se deve a uma má configuração do server por parte deles, nacionais ou importados.

Fica o alerta para futuros users que queiram hospedar seus portais por lá.

Obrigado pelas infos, aaron.

HUnmmmm má configuração? Qual seria, porque veja que o portal antes estava operando, dentro das especificações e de dois dias para cá segundo as logs do servidor, que começou seus picos de 12%, 15% chegando até à 17% de uso do processador?

Se fosse por parte de falha no servidor, em algum setor de configuração e ajustes creio eu que, o mesmo deveria ter acontecido imediatamente após à hospedagem conosco. Coisa que não ocorreu, de qualquer forma estaremos trabalhando em conjunto para resolver este problema, o mais rápido possível.

E manterei notícias sobre os avanços conseguidos neste tópico, porque pelo que vi uma outra pessoa já teve o mesmo problema. Assim podemos esclarescer muitas dúvidas que venham a surgir. Qualquer ajuda será bem-vinda!

ini  Ocasional   Postagens: 28

Aaraon escreveu:

... Não tenho chats nem nada que possa causar isso.
Eu tenho downloads, notícias, artigos, galeria de imagens, parcerias, contato, links e só.

Amigo,
Por um acaso você tem o fórum instalado? Mais especificamente o NewBB2?

Se tiver desative ele, desinstale e instale a versão anterior.

Referência: Carga em Exesso no Servidor, devido ao NewBB2

Aaraon Thomas  Iniciante   Postagens: 2

Salve Ini.

Eu tenho o Invision Power Board instalado. Nunca deu problema, mesmo quando eu ainda usava só o fórum em PHP e a página em HTML.

Mas valeu pela dica. Se eu for mudar de fórum um dia (mas no momento gosto muito do IPB) eu já tenho uma dica do que não usar!

izzy  Iniciante   Postagens: 0

Um jeito prático de poupar a banda do HOST em até 20% é abrir o arquivo .htaccess que fica na raíz do /public_html e colocar o seguinte comando:

php_flag zlib.output_compression on.
Php_value zlib.output_compression_level 4

Sacou?

Abraços,
Adinaldo

izzy  Iniciante   Postagens: 0

Adicionada para F.A.Q.

Delgado  Iniciante   Postagens: 10

Ué, fiz isso, aí o portal não abriu mais e deu o seguinte erro:
========================
Internal Server Error.
The server encountered an internal error or misconfiguration and was unable estou complete your request.
Please contact the server administrator, webmaster@geraçãobenjamim.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying estou use an ErrorDocument estou handle the request.
========================

Quando editei o arquivo ele estava em branco e só adicionei os comandos que você falou. Fiz algo errado?

luiz henrique dos santos borges  Iniciante De: taquara -Rio de Janeiro - RJ  Postagens: 6

Alguma ajuda? O portal continua comendo uma banda excessiva do processamento, chegou a atingir à casa dos 26% (vinte e seis porcentos)

Ficaria muito feliz, com uma colaboração da comunidade para sanar este problema.

Adinaldo escreveu:
Um jeito prático de poupar a banda do HOST em até 20% é abrir o arquivo .htaccess que fica na raíz do /public_html e colocar o seguinte comando:

php_flag zlib.output_compression on.
Php_value zlib.output_compression_level 4

Sacou?

Abraços,
Adinaldo
Ai .. aiai

Aaraon Thomas  Iniciante   Postagens: 2

Só para ajudar, olha o resumo:

Top Process %CPU 26.0 httpd [falerpg.com.br] [/site/modules/wfsection/]

Top Process %CPU 6.4 httpd [falerpg.com.br] [/site/modules/wfsection/article.php?articleid25]

Top Process %CPU 4.2 httpd [falerpg.com.br] [/site/modules/wfsection/images/mini_banner_manticora.jpg]

Eu não sei mais o que fazer...

izzy  Iniciante   Postagens: 0

Aaraon, tudo bom cara?

Tipo, faça o seguinte.

Vá no http://websiteoptimization.com/services/analyze/wso.php

Escreva teu endereço lá, ou seja, colocando o endereço principal de sua página no qual cai na página de capa http://falerpg.com.br/site/modules/news/

Observa-se que +/- 157 KB só de imagens, só que as imagens cavt4082a55781661.jpg e cavt407312bd3346c.gif são as piores.

Verifique os tamanhos das suas imagens...e principalmente flash...tente trocar o formato das imagens para jpg, png e diminuir o número de cores.

Bom, faça o seguinte: abra seu arquivo .htaccess na raiz do portal(se não tiver este arquivo faça um no bloco de notas) e ponha as seguintes linhas nele:

Php_flag zlib.output_compression on.
Php_value zlib.output_compression_level 4

Isso caso você esteja usando o Apache como servidor web, também desabilite a compressaõ gzip no menu de configurações do portal.

Outros locais onde você pode consultar sobre a instabilidade de seu site:

http://watson.addy.com/
http://hitbox.com/cgi-bin/page.cgi?tools/doc.
http://netmechanic.com/

Essa sdicas que eu falei, foram dadas por ideiafacil nesse tópico. Lá tinha uma pessoa com o mesmo problema do seu, e foi resolvido.

Bom, de qualquer modo não deem ouvidos a este tal de Endocrines. Ele não sabe o que diz, e muito menos ajuda para solucionar esse problema que está acontecendo com a maioria dos utilizadores do XOOPS.

Abraços,
Adinaldo.

izzy  Iniciante   Postagens: 0

Delgado!

Ué, fiz isso, aí o portal não abriu mais e deu o seguinte erro:
========================
Internal Server Error.
The server encountered an internal error or misconfiguration and was unable estou complete your request.
Please contact the server administrator, webmaster@geraçãobenjamim.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying estou use an ErrorDocument estou handle the request.
========================

Quando editei o arquivo ele estava em branco e só adicionei os comandos que você falou. Fiz algo errado?

Não, você ainda não fez nada errado. Está tudo certo!
O problema é que o seu HOST não deixa fazer essas alterações no .htaccess, tem alguma restrição.

Abraços,
Adinaldo.

izzy  Iniciante   Postagens: 0

Fora do contexto, segue o tópico normalmente.

Aaraon Thomas  Iniciante   Postagens: 2

Torçam.

Implementei o cache longo, arrumei o .htaccess e vamos ver no que dá...

luiz henrique dos santos borges  Iniciante De: taquara -Rio de Janeiro - RJ  Postagens: 6

Aaraon, as alterações no Apache com Fedora 3 tiveram melhora deixando o seu uso em torno de 5%

Mas mesmo assim ainda continua alto, realmente não sei o motivo disto estar acontecendo, já que antes de efetuar sua atualização o portal funcionava dentro dos conformes.

Será que algum path de atualizaçÃo está com um furo, aumentando assim o uso da CPU?

Creio que nosso problema deve ser enfrentado por muitos outros utilizadores, mas deve passar desapercebido aos olhos dos donos dos servidores. já que, um server com muitos clientes 200 por exemplo terá um uso alto, principalmente se uma pessoa não analisar corretamente os logs do server.

luiz henrique dos santos borges  Iniciante De: taquara -Rio de Janeiro - RJ  Postagens: 6

Se foi corrigido o erro em minha assinatura, creio que não esteja sendo correto postar uma mensagem aqui neste tópico.
Assunto encerrado por favor.

Basta que me fosse enviado uma PVT, sobre o mesmo. Reintero que pouco me importo com isso, desde que em prol da comunidade XOOPS. Apesar de ser dono de host, sou acima de tudo uma pessoa preocupada em corrigir eventuais falhas em alguns sistemas, da maneira que posso ajudar na medida do possível.

E tal forma no momento, é apenas disponibilizando informações concretas que possuo.

Gislaine  Ocasional   Postagens: 36

Obrigado Endocrines, continue com o bom trabalho em prol do XOOPS.

A sua participação e demais utilizadores é muito importante para nos.

Voltando ao tema de consumo.

Precisa ser analisado os módulos instalados. Utilizando os módulos core não temos problemas, mas por exemplo:

- A utilização do wf-sections versões anteriores a 2.0.5 duplicam o consumo por possuir querys lentas e grandes.
- Excesso de blocos com acesso a banco com retorno em arrays. Eles usam muita memoria e processamentos de cpu para todos os utilizadores.
- módulos contadores com acesso a bancos externos e internos.
- módulos com editores visuais e seus codigos. Todo editor visual por natureza depende de muito codigo e com isto intensas recargas para diversos utilizadores para disponibilizar estes recursos.
- Ma utilização de cache ou simplesmente, não utilizar ou não limpar os caches e templates_c pelo menos uma vez por semana.

Agora um estudo particular nosso, mas somente em cima do padrao deste CMS e temos o seguinte:

1 - XOOPS consome menos que phpnuke, postnuke, xaraya, e107 e tiki.
2 - phpwebsite consome menos que o XOOPS.

Agora conforme você vai agregando módulos aos cms as coisas podem se complicar mais ainda. A melhor estabilidade foi encontrada no tiki entre todos, mas com carga animal de codigo.
Resumindo, para evitar o uso excessivo nos servidores deve ter um bom balanceamento entre sua necessidade e hospedagem.
Maquinas mau configuradas contribuem bastante para os problemas tambem. XOOPS

Algumas coisas são reais e testadas, outras são observações pessoais minhas apenas.

maumed  Iniciante   Postagens: 2

Interessante. Gostei do post, Gisa_Iagami

Mas não entendi aparte do templates_c. Como o XOOPS usa essa cache? porque não limpa-la pode gerar uma sobrecarga?
Maurício

izzy  Iniciante   Postagens: 0

E aí? problema resolvido? Como anda essa questão?

Aaraon Thomas  Iniciante   Postagens: 2

Salve Adinaldo!

Até onde eu sabia está OK. Chutei alto os valores do cache e não recebi mais nenhum comentário do host...

izzy  Iniciante   Postagens: 0

Obrigado pelo rápido retorno Aaron!

Tem mais dicas para você utilizar.

O functions.php fica no diretório include, este arquivo aparece sempre quando ele é solicitado no login do portal por exemplo.

Para economizar 80% da banda do portal, coloque este arquivo dentro do diretório include. Esse arquivo foi modificado por TOPET05 e você notará rapidamente a diferença.

Clique aqui para baixá-lo.

Abraços,
Adinaldo

Aaraon Thomas  Iniciante   Postagens: 2

Putz!

Muito obrigado pela ajuda Adinaldo. Eu coloquei o arquivo lá.

Vamos ver no que dá. Eu vou falar com o host e perguntar se deu alguma mudança.

izzy  Iniciante   Postagens: 0

Nem precisa você falar com o HOST Aaron!

Basta você entrar no CPANEL localizar o Campo Gerenciador de estatísticas, você clica no LOG de transferência, e é por lá que você irá verificar o aumento e a utilização do seu portal no HOST.

Lá tem estatísicas da capacidade usada, tem também outras coisas a mais como o espaço em disco utilizado etc.

Abraços,
Adinaldo

Aaraon Thomas  Iniciante   Postagens: 2

Salve Adinaldo.

Eu realmente não acho o lugar onde fala sobre a utilização do banco de dados. No máximo sei que eles têm 10.07 Megabytes, mas isso não ajuda muito...

izzy  Iniciante   Postagens: 0

Hum, o CPanel seu acho que é diferente...

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 31 visitantes neste momento... (17 na seção Fóruns)

Associados: 0
Anônimos: 31

outros...

Banner XOOPS Cube