Vulnerabilidade no xcgallery

  • Identifique-se para criar novos tópicos neste fórum
  • Visitantes anônimos não podem postar neste fórum
Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

Há uma vulnerabilidade no xcgal, meu portal foi atacado, e todas as imagens dos albums sumiram, junto com os comentários, o engraçado é que as categorias e os albums em si continuam normais e todas as imagens estão no ftp. Resumindo, todas as imagens sumiram dos albums, isso não é um bug, porque eu uso o xcgal há muito tempo e com um grande volume de fotos (tenho um portal de festas), se essa vulnerabilidade ou seja lá o que for realmente existir tem que ser detectada com urgencia porque duma hora para outra isso aconteceu, todas as imagens dos albums sumiram de uma vez, porem o resto ficou intacto!

Valker Vacilão Silva  Iniciante De: Brasília - DF - Brasil  Postagens: 17

Isso não é algum problema no banco de dados?

O Smurfius, salvo engano, andou relatando problemas quando tinha grande quantidade de fotos. Só não lembro mais a qual módulo ele se referiu.

Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

Val, meu portal tem duas franquias, uma em Porto Velho e outra em Rio Branco, a de PV é mais antiga e recebe um número de imagens e visitas muito maior que a de Rio Branco (o portal afetado), tudo indica que há alguma vulnerabilidade no módulo, que alguém se aproveitou dela. Não tem explicação as imagens e as thumbnails estárem todas lá no FTP e as categorias e albums intactos, só que vazios, sem nada dentro, e o pior, de uma hora para outra sem eu ter mechido no portal nesse intervalo!

Mauro  Membro De: Recife - Pernambuco - Brasil  Postagens: 164

não conheço muito o xcGallery.
Mas... Já tentou executar o comando de raparo de tabelas.
No seu banco MySQL?
As vezes ocorre algum problema numa tabela então.
Ela fica travada fazendo com que alguns dados não sejam.
Exibidos até que seja feito o reparo na tabela... talves seja o seu caso.

Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

Vasculhei as tabelas e realmente uma está corrompida, a xoops_xcgal_pictures, deu o seguinte erro:

Can't open file: 'xoops_xcgal_pictures.MYI'. (errno: 145)

Como posso repara-la pelo phpmyadmin ou seja lá por onde for?

Mas continuo achando de há algum problema no módulo, uso o optimizer todo dia, isso ocorreu em um intervalo de tempo que eu nem sequer entrei no portal, e sou o único admin.

Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

O Vacilão via MSN me falou como fazer via phpmyadmin, mas pouco tempo depois o mesmo ocorreu com o portal de porto velho, isso é coincidência demais para ser verdade, há algo errado no módulo...

Mauro  Membro De: Recife - Pernambuco - Brasil  Postagens: 164

burnout escreveu:
Vasculhei as tabelas e realmente uma está corrompida, a xoops_xcgal_pictures, deu o seguinte erro:

Can't open file: 'xoops_xcgal_pictures.MYI'. (errno: 145)

Como posso repara-la pelo phpmyadmin ou seja lá por onde for?

Sim no phpMyAdmin tem como fazer.
Abre a tabela e vai no menu "Operations"
Que aparece a opção "reparar tabela" é só clicar no.
Link "reparar tabela".

Ou então usa a SQL :
REPAIR TABLE `nome_tabela`

izzy  Iniciante   Postagens: 0

Tem um módulo em XOOPS que faz isso, mas eu não me recordo o nome..

Abraços,
Adinaldo

Mauro  Membro De: Recife - Pernambuco - Brasil  Postagens: 164

Oi burnout.
Segue alguns números de erros em tabelas no mysql.
Cujo o seu se encontra na lista.

126 = Index file is crashed / Wrong file format.
127 = Record-file is crashed.
132 = Old database file.
134 = Record was already deleted (or record file crashed)
135 = No more room in record file.
136 = No more room in index file.
141 = Duplicate unique key or constraint on write or update.
144 = Table is crashed and last repair failed.
145 = Table was marked as crashed and should be repaired.

No endereço abaixo você pode consultar mais sobre o assunto.
E como resolve-lo.
http://dev.mysql.com/doc/mysql/pt/Repair.html

Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

O problema já foi resolvido, era a tabela xcgal_images que estava corrompida, agora estou falando com os desenvolvedores do módulo para ver se resolvem o problema definitivamente.

Mauro  Membro De: Recife - Pernambuco - Brasil  Postagens: 164

Oi burnout.
Que bom que conseguiu resolver seu trouble.
Se tiver algum problema no xcGallery.
Vai ver esteja em alguma parte do codigo do.
Módulo que esteja mexendo nos indices da tabela.
Já que o problema foi em um aquivo ".MYI"

Hamilton Rocha  Participativo De: Rio Branco - AC  Postagens: 85

É eu também acho, passei tudo em detalhes para o pessoal do que mantem o xcgal. Vamos ver se achamos o problema.

  Pesquisa avançada






Entrada

Codinome:


Senha:





Perdeu a senha?  |Cadastre-se!


Quem nos visita
Há 47 visitantes neste momento... (22 na seção Fóruns)

Associados: 0
Anônimos: 47

outros...

Banner XOOPS Cube